Re: [PATCH] drm/i915: Rename global i915 to i915_modparams

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Mon, 18 Sep 2017 21:12:25 +0200, Chris Wilson <chris@xxxxxxxxxxxxxxxxxx> wrote:

Quoting Michal Wajdeczko (2017-09-18 19:55:07)
Our global struct with params is named exactly the same way
as new preferred name for the drm_i915_private function parameter.
To avoid such name reuse lets use different name for the global.

v4: introduction of mkwrite()

Credits-to: Coccinelle

@@
identifier n;
expression e;
@@

(
-       i915.n = e;
+       i915_modparams_mkwrite()->n = e;
|
-       i915.n++;
+       i915_modparams_mkwrite()->n++;
|
-       i915.n--;
+       i915_modparams_mkwrite()->n--;
|
-       i915.n
+       i915_modparams.n
)

Did this also catch s/&i915&i915_modparams/?


No, but since it was in macro definition, it was unaccessible to Coccinelle anyway

Michal
_______________________________________________
Intel-gfx mailing list
Intel-gfx@xxxxxxxxxxxxxxxxxxxxx
https://lists.freedesktop.org/mailman/listinfo/intel-gfx




[Index of Archives]     [Linux USB Devel]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]
  Powered by Linux