On Thu, Aug 03, 2017 at 01:42:50PM +0100, Tvrtko Ursulin wrote: > From: Tvrtko Ursulin <tvrtko.ursulin@xxxxxxxxx> > > To the best of my recollection the page flipping test was added > simply to start exercising page flips with 90/270 rotation. > > There is no need to do 60 flips which can take quite some time > because we test each pipe and then each fb geometry. And > calling this a stress test is also not matching the original > idea of the test. > > So remove the stress from the name and reduce the number of > flips to three only. > > Signed-off-by: Tvrtko Ursulin <tvrtko.ursulin@xxxxxxxxx> > Cc: Daniel Vetter <daniel.vetter@xxxxxxxx> > --- > tests/intel-ci/extended.testlist | 2 +- fyi, extended.testlist is dead, definitely for everything minus gem_|prime_, because we just run them all. I guess time for me to create a patch to remove it. > tests/kms_rotation_crc.c | 4 ++-- > 2 files changed, 3 insertions(+), 3 deletions(-) > > diff --git a/tests/intel-ci/extended.testlist b/tests/intel-ci/extended.testlist > index 17eed013f810..fb71091758c6 100644 > --- a/tests/intel-ci/extended.testlist > +++ b/tests/intel-ci/extended.testlist > @@ -82,7 +82,7 @@ igt@gem_ringfill@vebox-bomb > igt@gem_userptr_blits@stress-mm > igt@gem_userptr_blits@stress-mm-invalidate-close > igt@gem_userptr_blits@stress-mm-invalidate-close-overlap > -igt@kms_rotation_crc@primary-rotation-90-flip-stress > +igt@kms_rotation_crc@primary-rotation-90-flip > igt@pm_rpm@gem-execbuf-stress > igt@pm_rpm@gem-execbuf-stress-extra-wait > igt@pm_rpm@gem-execbuf-stress-pc8 > diff --git a/tests/kms_rotation_crc.c b/tests/kms_rotation_crc.c > index 83e37f126f40..a04a2e68547d 100644 > --- a/tests/kms_rotation_crc.c > +++ b/tests/kms_rotation_crc.c > @@ -650,10 +650,10 @@ igt_main > test_plane_rotation(&data, DRM_PLANE_TYPE_PRIMARY); > } > > - igt_subtest_f("primary-rotation-90-flip-stress") { > + igt_subtest_f("primary-rotation-90-flip") { > igt_require(gen >= 9); > data.override_tiling = 0; > - data.flip_stress = 60; > + data.flip_stress = 3; s/flip_stress/flips/ as a bikeshed, to avoid confusion. Either way: Reviewed-by: Daniel Vetter <daniel.vetter@xxxxxxxx> > data.rotation = IGT_ROTATION_90; > test_plane_rotation(&data, DRM_PLANE_TYPE_PRIMARY); > } > -- > 2.9.4 > -- Daniel Vetter Software Engineer, Intel Corporation http://blog.ffwll.ch _______________________________________________ Intel-gfx mailing list Intel-gfx@xxxxxxxxxxxxxxxxxxxxx https://lists.freedesktop.org/mailman/listinfo/intel-gfx