We have 3 different types of macros to pick registers with multiple instances and each of these types is coded in a different way. I like consistency, so I wrote this series in order to try to make our code a little more clear regarding our options and their differences. Besides the consistency aspect, this series also does a few renames. I'm kinda afraid this series may get stuck in an endless bikeshed regarding the names. I know the current names are not very good, but at least the naming is consistent now, so I think there's value in merging the series. Regardless, I'm completely open to good naming suggestions. The only test I've done in the series was to boot SKL. Let's see what the CI system has to say about it. Cc: Rodrigo Vivi <rodrigo.vivi@xxxxxxxxx> Paulo Zanoni (7): drm/i915: reorder the register picking macros drm/i915: _MMIO_PORT3 takes a port as an argument drm/i915: use variable arguments for the macros that call _PICK drm/i915: rename _PICK to _PICK3 drm/i915: add _PICK macro for the "a + index * (b - a)" macros drm/i915: also move version 2 of the register picking macros up drm/i915: extract a _PICK2 macro drivers/gpu/drm/i915/i915_reg.h | 69 +++++++++++++++++++++-------------------- 1 file changed, 36 insertions(+), 33 deletions(-) -- 2.9.4 _______________________________________________ Intel-gfx mailing list Intel-gfx@xxxxxxxxxxxxxxxxxxxxx https://lists.freedesktop.org/mailman/listinfo/intel-gfx