Mahesh Kumar schreef op di 13-06-2017 om 11:34 [+0530]: > This patch make naming of fixed-point wrappers consistent > operation_<any_post_operation>_<1st operand>_<2nd operand> > also shorten the name for fixed_16_16 to fixed16 > > s/u32_to_fixed_16_16/u32_to_fixed16 > s/fixed_16_16_to_u32/fixed16_to_u32 > s/fixed_16_16_to_u32_round_up/fixed16_to_u32_round_up > s/min_fixed_16_16/min_fixed16 > s/max_fixed_16_16/max_fixed16 > s/mul_u32_fixed_16_16/mul_u32_fixed16 > > always do division internal operation in 64 bits: > s/fixed_16_16_div/div_fixed16 > s/fixed_16_16_div_64/div_fixed16 > > Introduce Addition wrappers for fixed16 > add_fixed16 : takes 2 fixed_16_16_t variable & returns fixed16_16_t > add_fixed16_u32 : takes fixed_16_16_t & u32 variable & returns > fixed16_16_t I think to make it readable, the additions should be done separately. mul_round_up_u32_fixed16 seems like it should use clamp_u64_to_fixed16, perhaps others too. Maybe do it as a preparation patch so this patch strictly does the renaming for review? _______________________________________________ Intel-gfx mailing list Intel-gfx@xxxxxxxxxxxxxxxxxxxxx https://lists.freedesktop.org/mailman/listinfo/intel-gfx