On Mon, 2017-06-05 at 22:07 +0100, Chris Wilson wrote: > Quoting Rodrigo Vivi (2017-06-05 21:21:49) > > This patch clean up a bit the platform definition block in > > a way to avoid duplications and to let clear that GT3 for > > the current platform only have the extra Media engine. > > > > v2: Kabylake IS_KABYLAKE as Anusha noticed. > > > > Cc: Anusha Srivatsa <anusha.srivatsa@xxxxxxxxx> > > Signed-off-by: Rodrigo Vivi <rodrigo.vivi@xxxxxxxxx> > > --- > > drivers/gpu/drm/i915/i915_pci.c | 66 ++++++++++++++++++++--------------------- > > 1 file changed, 33 insertions(+), 33 deletions(-) > > > > diff --git a/drivers/gpu/drm/i915/i915_pci.c b/drivers/gpu/drm/i915/i915_pci.c > > index cf43dc1..0e0606d 100644 > > --- a/drivers/gpu/drm/i915/i915_pci.c > > +++ b/drivers/gpu/drm/i915/i915_pci.c > > @@ -312,17 +312,21 @@ > > .has_full_48bit_ppgtt = 1, \ > > .has_64bit_reloc = 1 > > > > +#define BDW_PLATFORM \ > > + BDW_FEATURES, \ > > + .gen = 8, \ > > + .platform = INTEL_BROADWELL > > + > > +#define EXTRA_MEDIA_ENGINE \ > > + .ring_mask = RENDER_RING | BSD_RING | BLT_RING | VEBOX_RING | BSD2_RING > > Are you planning to call the next one EXTRA_EXTRA_ENGINES? I wondered to add as plural but since we currently add only one extra I figured that singular was better and if we end up adding more we change the mask name later. > > The mask is much more understandable and reviewable than a misleading > name like EXTRA_MEDIA_ENGINE. Yeap, indeed a bad name... Just couldn't figure a better name. I'm open for suggestions. My goal with this change is to respond quickly to the question: What is different on GT3 so anyone looking to this block would quickly respond: Oh, ah extra engine for media... But maybe be a bit more specific #define BSD2_RING \ > + .ring_mask = RENDER_RING | BSD_RING | BLT_RING | VEBOX_RING | BSD2_RING > Thanks, Rodrigo. > -Chris _______________________________________________ Intel-gfx mailing list Intel-gfx@xxxxxxxxxxxxxxxxxxxxx https://lists.freedesktop.org/mailman/listinfo/intel-gfx