On Fri, May 05, 2017 at 02:50:46PM +0100, Tvrtko Ursulin wrote: > > On 03/05/2017 12:37, Chris Wilson wrote: > > [snip] > > >+#include <linux/list.h> > >+ > >+static inline void __list_del_many(struct list_head *head, > >+ struct list_head *first) > >+{ > >+ head->next = first; > >+ first->prev = head; > >+} > > Btw it is similar to __list_cut_position, but without the second > list you don't need and deleting the first entry which you do not > want. > > So I am just thinking if consistent naming with the core function > would be beneficial like __list_cut_position_before/exclusive? It's not a cut, as in we don't create two seperate lists. It is more of splice with itself, though I did look at cut and wonder if it would magically eliminate the unwanted paths but no.. Still favouring a list_del prefix. Once upon a time I just opencoded this, it's far easily than trying to work out a good name :) -Chris -- Chris Wilson, Intel Open Source Technology Centre _______________________________________________ Intel-gfx mailing list Intel-gfx@xxxxxxxxxxxxxxxxxxxxx https://lists.freedesktop.org/mailman/listinfo/intel-gfx