On Thu, Apr 27, 2017 at 04:12:52PM -0700, Michel Thierry wrote: > +#define WA_REG_WR_GUC_RESTORE(addr, val) do { \ > + const int r = guc_wa_add(dev_priv, (addr), (val)); \ > + if (r) \ > + return r; \ > + } while (0) Try to avoid burying returns inside macros. Does this macro help code readability? Would perhaps just a table of registers + values be easier? -Chris -- Chris Wilson, Intel Open Source Technology Centre _______________________________________________ Intel-gfx mailing list Intel-gfx@xxxxxxxxxxxxxxxxxxxxx https://lists.freedesktop.org/mailman/listinfo/intel-gfx