On pe, 2017-03-10 at 08:28 -0800, Oscar Mateo wrote: > When initializing the GuC log struct, there is an object we need to > allocate always, since the GuC needs its address at fw load time. > The rest is only needed during runtime, in the sense that we only > create if we actually enable GuC logging. Make that distinction > explicit by subdividing further the intel_guc_log struct. > > v2: Call the new struct "runtime", instead of "extras" (Joonas). > > Cc: Daniele Ceraolo Spurio <daniele.ceraolospurio@xxxxxxxxx> > Cc: Joonas Lahtinen <joonas.lahtinen@xxxxxxxxxxxxxxx> > Reviewed-by: Michal Wajdeczko <michal.wajdeczko@xxxxxxxxx> > Signed-off-by: Oscar Mateo <oscar.mateo@xxxxxxxxx> <SNIP> > @@ -416,9 +416,9 @@ static int guc_log_create_extras(struct intel_guc *guc) > * or scheduled later on resume. This way the handling of work > * item can be kept same between system suspend & rpm suspend. > */ > - guc->log.flush_wq = alloc_ordered_workqueue("i915-guc_log", > + guc->log.runtime.flush_wq = alloc_ordered_workqueue("i915-guc_log", > WQ_HIGHPRI | WQ_FREEZABLE); Check indent here. I see this is as a major improvement in readability; Reviewed-by: Joonas Lahtinen <joonas.lahtinen@xxxxxxxxxxxxxxx> In the future, we might even refactor into guc_log_enable / guc_log_disable :) Regards, Joonas -- Joonas Lahtinen Open Source Technology Center Intel Corporation _______________________________________________ Intel-gfx mailing list Intel-gfx@xxxxxxxxxxxxxxxxxxxxx https://lists.freedesktop.org/mailman/listinfo/intel-gfx