General GuC/HuC cleanup simplifying logic, and moving chunks around, as the area is pretty rusty. A lot of logic were extracted from intel_guc_load() to other functions - it not only did handle the actual loading but had WA implementations and had the code thatenabled submission baked it. This is the first part of effort to clean it up. v2: rebase after HuC merge + feedback v3: even more renaming that aims to make things more semantic Arkadiusz Hiler (8): drm/i915/uc: Rename intel_?uc_{setup,load}() to _init_hw() drm/i915/uc: Drop superfluous externs in intel_uc.h drm/i915/huc: Add huc_to_i915 drm/i915/uc: Rename intel_?uc_init() to intel_?uc_fetch_fw() drm/i915/uc: Make intel_uc_fw_fetch() static drm/i915/guc: Extract param logic form guc_init drm/i915/guc: Simplify intel_guc_init_hw() drm/i915/uc: Simplify firwmare path handling drivers/gpu/drm/i915/i915_drv.c | 5 +- drivers/gpu/drm/i915/i915_drv.h | 5 + drivers/gpu/drm/i915/i915_gem.c | 2 +- drivers/gpu/drm/i915/intel_guc_loader.c | 354 ++++---------------------------- drivers/gpu/drm/i915/intel_huc.c | 57 +++-- drivers/gpu/drm/i915/intel_uc.c | 278 +++++++++++++++++++++++++ drivers/gpu/drm/i915/intel_uc.h | 27 ++- 7 files changed, 368 insertions(+), 360 deletions(-) -- 2.9.3 _______________________________________________ Intel-gfx mailing list Intel-gfx@xxxxxxxxxxxxxxxxxxxxx https://lists.freedesktop.org/mailman/listinfo/intel-gfx