Re: [PATCH i-g-t v4 00/11] tests/kms_atomic_transition add fence testing

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hi Robert,

Some minor comments on 5, 6, 9, 10 and 11. With those addressed, the
whole series is:

Reviewed-by: Brian Starkey <brian.starkey@xxxxxxx>

Thanks!
-Brian

P.S. Immediately after hitting send I realised I should have trimmed
that blob from my reply. Sorry for bouncing that back to everyone!

On Tue, Jan 31, 2017 at 08:25:09PM -0500, Robert Foss wrote:
This series adds in/out fence testing to kms_atomic_transition test and makes some minor cleanups.

This series can be found here:
https://git.collabora.com/cgit/user/robertfoss/intel-gpu-tools.git/log/?h=fences_$VER


Changes since v3:
 Rebased on upstream/master

 lib/igt_kms:
  - Change out_fence from int64_t to int32_t
  - Fixed build error halfway in the series
  - Change IN_FENCE_FD to be an int always
  - Change name of out_fence to out_fence_fd
  - Removed useless assert
  - Fixed erroneous fence_fd check in igt_atomic_commit()
  - Implemented igt_plane_set_fence_fd FD close logic
  - Properly close fd in igt_atomic_prepare_plane_commit()

 tests/kms_atomic:
  - Changed type of out_fence_ptr to int32_t

 tests/kms_atomic_transition:
  - Fixed indentation errors in prepare_fencing()
  - Added close() to callers of igt_plane_set_fence_fd with valid FDs
  - Move change atomic_commit to earlier commit to remove inter commit changes


Changes since v2:
 Rebased on upstream/master

 lib/igt_kms:
   - Reset plane->fence_fd to -1 during igt_atomic_prepare_plane_commit()
   - Rework out_fencs_ptr to be an int64_t named out_fence
   - Add igt_pipe_request_out_fence()

 tests/:
   - Switch to using igt_pipe_request_out_fence()
   - Close out_fence fd
   - Change out_fence to int64_t in run_transition_test()
   - Added comments noting that two testcases are not invalid
   - Added igt_pipe_get_last_out_fence() that wraps pipe->fence_out


Changes since v1:

 lib/igt_kms:
  - Added gtk-doc for exported symbols
  - Changed integer casting to avoid potential issues
  - Changed out_fence_ptr type to int64_t*
  - Fixed igt_plane_set_fence_fd comment

 tests/:
  - Rework timeout change in commit_display()
  - Extract plane_invalid_params_fence() out plane_invalid_params()
  - Extract crtc_invalid_params_fence() out crtc_invalid_params()
  - Prevent add igt_require_sw_sync to subtests using sw_sync



Gustavo Padovan (8):
 tests/kms_atomic_transition: use igt timeout instead of blocking
 lib/igt_kms: move igt_kms_get_alt_edid() to the right place
 lib/igt_kms: export properties names
 tests/kms_atomic: use global atomic properties definitions
 lib/igt_kms: Add support for the OUT_FENCE_PTR property
 tests/kms_atomic: stress possible fence settings
 tests/kms_atomic_transition: add fencing parameter to
   run_transition_tests
 tests/kms_atomic_transition: add in_fences tests

Robert Foss (3):
 lib/igt_kms: Add support for the IN_FENCE_FD property
 tests/kms_atomic_transition: add out_fences tests
 lib/igt_kms: Added igt_pipe_get_last_out_fence()

lib/igt_kms.c                 | 115 +++++++++++++---
lib/igt_kms.h                 |  35 ++++-
tests/kms_atomic.c            | 310 +++++++++++++++++++++++++++++-------------
tests/kms_atomic_transition.c | 184 +++++++++++++++++++++++--
tools/intel_vbt_decode        | Bin 0 -> 384448 bytes
5 files changed, 511 insertions(+), 133 deletions(-)
create mode 100755 tools/intel_vbt_decode

--
2.11.0.453.g787f75f05

_______________________________________________
Intel-gfx mailing list
Intel-gfx@xxxxxxxxxxxxxxxxxxxxx
https://lists.freedesktop.org/mailman/listinfo/intel-gfx




[Index of Archives]     [Linux USB Devel]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]
  Powered by Linux