On Mon, 24 Oct 2016, Imre Deak <imre.deak@xxxxxxxxx> wrote: > This check is open-coded in a few places, so it makes sense to simplify > things by having a helper for it similar to the rest of DPCD feature > helpers. > > v2: (Jani) > - Move the helper to drm_dp_helper.h. > - Split out this change to a separate patch. > > Cc: Jani Nikula <jani.nikula@xxxxxxxxx> > Cc: dri-devel@xxxxxxxxxxxxxxxxxxxxx > Signed-off-by: Imre Deak <imre.deak@xxxxxxxxx> DP 1.4 has changed the name of "branch" devices, but I think this is good. Reviewed-by: Jani Nikula <jani.nikula@xxxxxxxxx> > --- > drivers/gpu/drm/i915/intel_dp.c | 11 ++++------- > include/drm/drm_dp_helper.h | 6 ++++++ > 2 files changed, 10 insertions(+), 7 deletions(-) > > diff --git a/drivers/gpu/drm/i915/intel_dp.c b/drivers/gpu/drm/i915/intel_dp.c > index f30db8f..3c2293b 100644 > --- a/drivers/gpu/drm/i915/intel_dp.c > +++ b/drivers/gpu/drm/i915/intel_dp.c > @@ -1459,8 +1459,7 @@ static void intel_dp_print_hw_revision(struct intel_dp *intel_dp) > if ((drm_debug & DRM_UT_KMS) == 0) > return; > > - if (!(intel_dp->dpcd[DP_DOWNSTREAMPORT_PRESENT] & > - DP_DWN_STRM_PORT_PRESENT)) > + if (!drm_dp_is_branch(intel_dp->dpcd)) > return; > > len = drm_dp_dpcd_read(&intel_dp->aux, DP_BRANCH_HW_REV, &rev, 1); > @@ -1478,8 +1477,7 @@ static void intel_dp_print_sw_revision(struct intel_dp *intel_dp) > if ((drm_debug & DRM_UT_KMS) == 0) > return; > > - if (!(intel_dp->dpcd[DP_DOWNSTREAMPORT_PRESENT] & > - DP_DWN_STRM_PORT_PRESENT)) > + if (!drm_dp_is_branch(intel_dp->dpcd)) > return; > > len = drm_dp_dpcd_read(&intel_dp->aux, DP_BRANCH_SW_REV, &rev, 2); > @@ -3615,8 +3613,7 @@ intel_dp_get_dpcd(struct intel_dp *intel_dp) > if (!is_edp(intel_dp) && !intel_dp->sink_count) > return false; > > - if (!(intel_dp->dpcd[DP_DOWNSTREAMPORT_PRESENT] & > - DP_DWN_STRM_PORT_PRESENT)) > + if (!drm_dp_is_branch(intel_dp->dpcd)) > return true; /* native DP sink */ > > if (intel_dp->dpcd[DP_DPCD_REV] == 0x10) > @@ -4134,7 +4131,7 @@ intel_dp_detect_dpcd(struct intel_dp *intel_dp) > return connector_status_connected; > > /* if there's no downstream port, we're done */ > - if (!(dpcd[DP_DOWNSTREAMPORT_PRESENT] & DP_DWN_STRM_PORT_PRESENT)) > + if (!drm_dp_is_branch(dpcd)) > return connector_status_connected; > > /* If we're HPD-aware, SINK_COUNT changes dynamically */ > diff --git a/include/drm/drm_dp_helper.h b/include/drm/drm_dp_helper.h > index 2a79882..55bbeb0 100644 > --- a/include/drm/drm_dp_helper.h > +++ b/include/drm/drm_dp_helper.h > @@ -690,6 +690,12 @@ drm_dp_tps3_supported(const u8 dpcd[DP_RECEIVER_CAP_SIZE]) > dpcd[DP_MAX_LANE_COUNT] & DP_TPS3_SUPPORTED; > } > > +static inline bool > +drm_dp_is_branch(const u8 dpcd[DP_RECEIVER_CAP_SIZE]) > +{ > + return dpcd[DP_DOWNSTREAMPORT_PRESENT] & DP_DWN_STRM_PORT_PRESENT; > +} > + > /* > * DisplayPort AUX channel > */ -- Jani Nikula, Intel Open Source Technology Center _______________________________________________ Intel-gfx mailing list Intel-gfx@xxxxxxxxxxxxxxxxxxxxx https://lists.freedesktop.org/mailman/listinfo/intel-gfx