On ke, 2016-07-27 at 12:14 +0100, Chris Wilson wrote: > Move the single line to the callsite as the name is now misleading, and > the purpose is solely to add the request to the execution queue. > > Signed-off-by: Chris Wilson <chris@xxxxxxxxxxxxxxxxxx> > --- > drivers/gpu/drm/i915/i915_gem_execbuffer.c | 9 +-------- > 1 file changed, 1 insertion(+), 8 deletions(-) > > diff --git a/drivers/gpu/drm/i915/i915_gem_execbuffer.c b/drivers/gpu/drm/i915/i915_gem_execbuffer.c > index 0593ea3ba211..63984c4d8e5a 100644 > --- a/drivers/gpu/drm/i915/i915_gem_execbuffer.c > +++ b/drivers/gpu/drm/i915/i915_gem_execbuffer.c > @@ -1211,13 +1211,6 @@ i915_gem_execbuffer_move_to_active(struct list_head *vmas, > } > } > > -static void > -i915_gem_execbuffer_retire_commands(struct i915_execbuffer_params *params) > -{ > - /* Add a breadcrumb for the completion of the batch buffer */ > - __i915_add_request(params->request, params->batch_obj, true); > -} > - > static int > i915_reset_gen7_sol_offsets(struct drm_i915_gem_request *req) > { > @@ -1692,7 +1685,7 @@ i915_gem_do_execbuffer(struct drm_device *dev, void *data, > > ret = execbuf_submit(params, args, &eb->vmas); > err_request: > - i915_gem_execbuffer_retire_commands(params); > + __i915_add_request(params->request, params->batch_obj, ret == 0); This adds a new behavior of no flushing if execbuf fails to submit, I guess it is intentional? Do mention in the commit message. Regards, Joonas > > err_batch_unpin: > /* -- Joonas Lahtinen Open Source Technology Center Intel Corporation _______________________________________________ Intel-gfx mailing list Intel-gfx@xxxxxxxxxxxxxxxxxxxxx https://lists.freedesktop.org/mailman/listinfo/intel-gfx