On Sat, Sep 18, 2021 at 11:24:27PM -0700, Arowa Suliman wrote: > Replaced the word Sanity with the inclusive word Validity. > src/ap/acs.c | 2 -- > src/ap/wpa_auth_ft.c | 4 ++-- > src/p2p/p2p_pd.c | 2 +- > src/pae/ieee802_1x_kay.c | 8 ++++---- > tests/hwsim/test_fst_config.py | 2 +- > tests/hwsim/test_wmediumd.py | 2 +- > tests/remote/run-tests.py | 6 +++--- > wpa_supplicant/ctrl_iface.c | 2 +- > wpa_supplicant/p2p_supplicant_sd.c | 4 ++-- Thanks, I'll apply the other ones, but the changes in tests/remote/run-tests.py would potentially break external users, so I cannot apply them without first understanding how this mechanism might be used. > diff --git a/tests/remote/run-tests.py b/tests/remote/run-tests.py > @@ -33,7 +33,7 @@ from hwsim_wrapper import run_hwsim_test > def usage(): > print("USAdGE: " + sys.argv[0] + " -t devices") > print("USAGE: " + sys.argv[0] + " -t check_devices") > - print("USAGE: " + sys.argv[0] + " -d <dut_name> -t <all|sanity|tests_to_run> [-r <ref_name>] [-c <cfg_file.py>] [-m <all|monitor_name>] [-h hwsim_tests] [-f hwsim_modules][-R][-T][-P][-S][-v]") > + print("USAGE: " + sys.argv[0] + " -d <dut_name> -t <all|validity|tests_to_run> [-r <ref_name>] [-c <cfg_file.py>] [-m <all|monitor_name>] [-h hwsim_tests] [-f hwsim_modules][-R][-T][-P][-S][-v]") This would break external scripts using these tests. > @@ -270,9 +270,9 @@ def main(): > - elif requested_tests[0] == "sanity": > + elif requested_tests[0] == "validity": > for test in tests: > - if test.__name__.startswith("test_sanity_"): > + if test.__name__.startswith("test_validity_"): > tests_to_run.append(test) In addition to that command line change, this replacement of the test case prefix would break any existing use of this functionality. That said, I don't see this test functionality being used anywhere in hostap.git, so this would need to depend on something completely external and if no such things exists, it would be better to just remove this command line argument completely. As far as this replacement of "sanity" with "validity" is concerned, I don't think "validity" would be clear for the purpose I think these were originally added: a quick set of tests to verify basic functionality ("sanity check") which is different from "validity check". "basic" would be a more accurate replacement should this functionality be needed, but still, that would break externally used interface, so this would need to more research on whether this functionality is really being used. -- Jouni Malinen PGP id EFC895FA _______________________________________________ Hostap mailing list Hostap@xxxxxxxxxxxxxxxxxxx http://lists.infradead.org/mailman/listinfo/hostap