On Sat, Apr 06, 2024 at 11:45:51AM -0500, Alex Elder wrote: > On 4/6/24 4:09 AM, Dan Carpenter wrote: > > On Fri, Apr 05, 2024 at 02:22:05PM -0700, Jackson Chui wrote: > > > On Thu, Apr 04, 2024 at 05:05:09PM -0500, Alex Elder wrote: > > > > On 4/3/24 7:16 PM, Jackson Chui wrote: > > > > > Reported by checkpatch: > > > > > > > > > > CHECK: Macro argument 'gcam' may be better as '(gcam)' to avoid > > > > > precedence issues > > > > > > > > I agree with your argument about the way the macro should be > > > > defined. But perhaps these gcam_*() functions could just > > > > be eliminated? > > > > > > > > I see 15 calls to gcam_err(), 1 call to gcam_dbg(), and none > > > > to gcam_info(). It would be a different patch, but maybe > > > > you could do that instead? > > > > > > > > -Alex > > > > > > > > > > > > > > > > > > Disambiguates '&' (address-of) operator and '->' operator precedence, > > > > > accounting for how '(gcam)->bundle->dev' is a 'struct device' and not a > > > > > 'struct device*', which is required by the dev_{dbg,info,err} driver > > > > > model diagnostic macros. Issue found by checkpatch. > > > > > > > > > > Signed-off-by: Jackson Chui <jacksonchui.qwerty@xxxxxxxxx> > > > > > --- > > > > > drivers/staging/greybus/camera.c | 6 +++--- > > > > > 1 file changed, 3 insertions(+), 3 deletions(-) > > > > > > > > > > diff --git a/drivers/staging/greybus/camera.c b/drivers/staging/greybus/camera.c > > > > > index a8173aa3a995..d82a2d2abdca 100644 > > > > > --- a/drivers/staging/greybus/camera.c > > > > > +++ b/drivers/staging/greybus/camera.c > > > > > @@ -180,9 +180,9 @@ static const struct gb_camera_fmt_info *gb_camera_get_format_info(u16 gb_fmt) > > > > > #define GB_CAMERA_MAX_SETTINGS_SIZE 8192 > > > > > -#define gcam_dbg(gcam, format...) dev_dbg(&gcam->bundle->dev, format) > > > > > -#define gcam_info(gcam, format...) dev_info(&gcam->bundle->dev, format) > > > > > -#define gcam_err(gcam, format...) dev_err(&gcam->bundle->dev, format) > > > > > +#define gcam_dbg(gcam, format...) dev_dbg(&((gcam)->bundle->dev), format) > > > > > +#define gcam_info(gcam, format...) dev_info(&((gcam)->bundle->dev), format) > > > > > +#define gcam_err(gcam, format...) dev_err(&((gcam)->bundle->dev), format) > > > > > static int gb_camera_operation_sync_flags(struct gb_connection *connection, > > > > > int type, unsigned int flags, > > > > > > > > > > Thanks for the feedback, Alex! > > > > > > I thought about refactoring it, but I feel it is worth keeping > > > the macro around. It acts as an apdater between callers, who > > > have 'gcam' and want to log and what the dynamic debug macros > > > expect. Without it, the code gets pretty ugly. > > > > Another idea would be to create a function: > > > > struct device *gcam_dev(struct gb_camera *gcam) > > { > > return &gcam->bundle->dev; > > } > > > > dev_dbg(gcam_dev(gcam), "received metadata ... > > > > (I don't know how to actually compile this code so I haven't tried it). > > Yes, I prefer this over the original suggestion. But > even here the gcam_dev() function doesn't add all that > much value; it saves four characters I guess. > > Jackson, the basic principle that makes me say I don't > like the wrapper macros is that the wrapper obscures > the simple call(s) to dev_dbg(), etc. If there was > something you wanted to do every time--along with > calling dev_dbg()--then maybe the wrapper would be > helpful, but instead it simply hides the standard call. > Better to have the code just use the functions kernel > programmers recognize. > > -Alex Dan, Alex I think both of you are spot on. I like the suggestion of adding 'gcam_dev()' as an accessor function and directly calling to 'dev_*'. I'm busy this weekend but will send out a new patch with this change next week. Jackson > > > > regards, > > dan carpenter > _______________________________________________ greybus-dev mailing list -- greybus-dev@xxxxxxxxxxxxxxxx To unsubscribe send an email to greybus-dev-leave@xxxxxxxxxxxxxxxx