On Sun, Feb 15, 2009 at 2:24 PM, Johannes Schindelin <Johannes.Schindelin@xxxxxx> wrote: > Hi, > > On Sun, 15 Feb 2009, Felipe Contreras wrote: > >> + switch (types) { >> + case TYPE_BOOL: type = T_BOOL; break; >> + case TYPE_INT: type = T_INT; break; >> + case TYPE_BOOL_OR_INT: type = T_BOOL_OR_INT; break; >> + default: break; >> + } > > Would it not be nicer to get rid of the variable named "type" and use > "types == TYPE_BOOL" and similar statements instead? I'm not too sure about that. If you read the code you might think you could actually have multiple types, but the same can be said about actions. Anyway, attached is a patch with that change. -- Felipe Contreras
Attachment:
0004-config-Improve-variable-type-handling.patch
Description: Binary data