Hi, On Sun, 15 Feb 2009, Felipe Contreras wrote: > + switch (types) { > + case TYPE_BOOL: type = T_BOOL; break; > + case TYPE_INT: type = T_INT; break; > + case TYPE_BOOL_OR_INT: type = T_BOOL_OR_INT; break; > + default: break; > + } Would it not be nicer to get rid of the variable named "type" and use "types == TYPE_BOOL" and similar statements instead? Ciao, Dscho -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html