Re: [PATCH] Add a built-in alias for 'stage' to the 'add' command

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On 12/2/08, Scott Chacon <schacon@xxxxxxxxx> wrote:
>  diff --git a/git.c b/git.c
>  index 89feb0b..9e5813c 100644
>  --- a/git.c
>  +++ b/git.c
>  @@ -266,6 +266,7 @@ static void handle_internal_command(int argc, const char **argv)
>         const char *cmd = argv[0];
>         static struct cmd_struct commands[] = {
>                 { "add", cmd_add, RUN_SETUP | NEED_WORK_TREE },
>  +               { "stage", cmd_add, RUN_SETUP | NEED_WORK_TREE },
>                 { "annotate", cmd_annotate, RUN_SETUP },
>                 { "apply", cmd_apply },
>                 { "archive", cmd_archive },

Nit-picking. There are some references to "git add" in builtin-add.c,
like help usage or error message ("Maybe you wanted to say 'git add
.'?\n"). Should it refer to "git stage" instead as well?
-- 
Duy
--
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html

[Index of Archives]     [Linux Kernel Development]     [Gcc Help]     [IETF Annouce]     [DCCP]     [Netdev]     [Networking]     [Security]     [V4L]     [Bugtraq]     [Yosemite]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Linux SCSI]     [Fedora Users]

  Powered by Linux