Andreas Ericsson <ae@xxxxxx> writes: > Junio C Hamano wrote: > ... >>> static struct funcname_pattern { >>> char *name; >>> char *pattern; >>> + int cflags; >> >> What does "C" stand for? > > "compile". It's the same name as regcomp(3) uses for the flags being > used to compile the regular expression. The full mnemonic name would > be regex_compile_flag, which is a bit unwieldy. Perhaps regcomp_flags > would be a good compromise? Ah, I see. When I saw that new field for the first time, I didn't think it will be used to store the bare flag values regcomp/regexec library would accept directly (I expected we would see #define or enum to tweak our own set of features, not limiting ourselves EXTENDED/ICASE etc. that regcomp/regexec library supports) IOW, it just did not click for me to look at "man 3 regcomp" which says: int regcomp(regex_t *preg, const char *regex, int cflags); So unless others feel that we might get a better layering separation by not storing REG_EXTENDED and stuff directly in that field (which was my initial reaction without looking at 4/4 which does store REG_EXTENDED there without our own enums), cflag is perfectly a good name here. Thanks --- I am bit under the weather and not thinking quite straight. -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html