The latest maintenance release GIT 1.5.3.7 is available at the usual places: http://www.kernel.org/pub/software/scm/git/ git-1.5.3.7.tar.{gz,bz2} (tarball) git-htmldocs-1.5.3.7.tar.{gz,bz2} (preformatted docs) git-manpages-1.5.3.7.tar.{gz,bz2} (preformatted docs) RPMS/$arch/git-*-1.5.3.7-1.$arch.rpm (RPM) What's cooking for upcoming feature release v1.5.4 has been stablizing, and hopefully this will be the last of v1.5.3 maintenance series. By the way, if you are the package maintainer of git for a distro, or the editor of an OSS oriented publication, and if you would like a copy of release announcements, please let me know, so that I can add your e-mail address to Bcc: on future announcement mails. Sorry, but I cannot handle subscription requests from individuals. ---------------------------------------------------------------- GIT v1.5.3.7 Release Notes ========================== Fixes since v1.5.3.6 -------------------- * git-send-email added 8-bit contents to the payload without marking it as 8-bit in a CTE header. * "git-bundle create a.bndl HEAD" dereferenced the symref and did not record the ref as 'HEAD'; this prevented a bundle from being used as a normal source of git-clone. * The code to reject nonsense command line of the form "git-commit -a paths..." and "git-commit --interactive paths..." were broken. * Adding a signature that is not ASCII-only to an original commit that is ASCII-only would make the result non-ASCII. "git-format-patch -s" did not mark such a message correctly with MIME encoding header. * git-add sometimes did not mark the resulting index entry stat-clean. This affected only cases when adding the contents with the same length as the previously staged contents, and the previous staging made the index entry "racily clean". * git-commit did not honor GIT_INDEX_FILE the user had in the environment. * When checking out a revision, git-checkout did not report where the updated HEAD is if you happened to have a file called HEAD in the work tree. * "git-rev-list --objects" mishandled a tree that points at a submodule. * "git cvsimport" was not ready for packed refs that "git gc" can produce and gave incorrect results. * Many scripted Porcelains were confused when you happened to have a file called "HEAD" in your work tree. Also it contains updates to the user manual and documentation. ---------------------------------------------------------------- Changes since v1.5.3.6 are as follows: Björn Steinbrink (3): git-commit.sh: Fix usage checks regarding paths given when they do not make sense t7005-editor.sh: Don't invoke real vi when it is in GIT_EXEC_PATH git-commit: Add tests for invalid usage of -a/--interactive with paths Brian Downing (2): config: correct core.loosecompression documentation config: clarify compression defaults J. Bruce Fields (7): git-remote.txt: fix example url user-manual: mention "..." in "Generating diffs", etc. Documentation: Fix references to deprecated commands user-manual: define "branch" and "working tree" at start user-manual: failed push to public repository user-manual: clarify language about "modifying" old commits user-manual: recovering from corruption Jan Hudec (1): Improve description of git-branch -d and -D in man page. Jeff King (5): send-email: add transfer encoding header with content-type Add basic cvsimport tests cvsimport: use rev-parse to support packed refs cvsimport: miscellaneous packed-ref fixes cvsimport: fix usage of cvsimport.module Johannes Schindelin (2): bundle create: keep symbolic refs' names instead of resolving them Replace the word 'update-cache' by 'update-index' everywhere Johannes Sixt (1): t7003-filter-branch: Fix test of a failing --msg-filter. Junio C Hamano (11): format-patch -s: add MIME encoding header if signer's name requires so test format-patch -s: make sure MIME content type is shown as needed ce_match_stat, run_diff_files: use symbolic constants for readability git-add: make the entry stat-clean after re-adding the same contents t2200: test more cases of "add -u" Make test scripts executable. Fix sample pre-commit hook git-checkout: describe detached head correctly scripts: do not get confused with HEAD in work tree Fix typo in t4008 test title GIT 1.5.3.7 Linus Torvalds (1): Fix rev-list when showing objects involving submodules Matthieu Moy (1): Doc fix for git-reflog: mention @{...} syntax, and <ref> in synopsys. Rémi Vanicat (1): Make GIT_INDEX_FILE apply to git-commit Steffen Prohaska (1): user-manual: Add section "Why bisecting merge commits can be harder ..." - To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html