Rubén Justo <rjusto@xxxxxxxxx> writes: > On Wed, May 22, 2024 at 10:40:18AM -0700, Junio C Hamano wrote: > >> Not really. The name "old_fd2" strongly implies "where did fd#2 >> come from?" and it did not come from fd#0, did it? > > Perhaps "close_fd2" is a better name?: > @@ pager.c: static void close_pager_fds(void) > /* signal EOF to pager */ > close(1); > - close(2); > -+ if (old_fd2 != -1) > ++ if (close_fd2) > + close(2); That's a very straight-forward name that says what effect anybody who assigns to the variable wants to see.