On Wed, May 22, 2024 at 10:40:18AM -0700, Junio C Hamano wrote: > Not really. The name "old_fd2" strongly implies "where did fd#2 > come from?" and it did not come from fd#0, did it? Perhaps "close_fd2" is a better name?: @@ pager.c: int pager_use_color = 1; static struct child_process pager_process; static const char *pager_program; -+static int old_fd2 = -1; ++static int close_fd2; /* Is the value coming back from term_columns() just a guess? */ static int term_columns_guessed; @@ pager.c: static void close_pager_fds(void) /* signal EOF to pager */ close(1); - close(2); -+ if (old_fd2 != -1) ++ if (close_fd2) + close(2); }