On Sat, May 11, 2024 at 04:29:42PM -0700, Junio C Hamano wrote: > * ps/builtin-config-cleanup (2024-05-10) 23 commits > - fixup! builtin/config: move location options into local variables > - builtin/config: pass data between callbacks via local variables > - builtin/config: convert flags to a local variable > - builtin/config: track "fixed value" option via flags only > - builtin/config: convert `key` to a local variable > - builtin/config: convert `key_regexp` to a local variable > - builtin/config: convert `regexp` to a local variable > - builtin/config: convert `value_pattern` to a local variable > - builtin/config: convert `do_not_match` to a local variable > - builtin/config: move `respect_includes_opt` into location options > - builtin/config: move default value into display options > - builtin/config: move type options into display options > - builtin/config: move display options into local variables > - builtin/config: move location options into local variables > - builtin/config: refactor functions to have common exit paths > - config: make the config source const > - builtin/config: check for writeability after source is set up > - builtin/config: move actions into `cmd_config_actions()` > - builtin/config: move legacy options into `cmd_config()` > - builtin/config: move subcommand options into `cmd_config()` > - builtin/config: move legacy mode into its own function > - builtin/config: stop printing full usage on misuse > - Merge branch 'ps/config-subcommands' into ps/builtin-config-cleanup > (this branch uses ps/config-subcommands.) > > Code clean-up to reduce inter-function communication inside > builtin/config.c done via the use of global variables. > > Will merge to 'next'? > source: <cover.1715339393.git.ps@xxxxxx> There are a few smallish comments that I want to address, so I'll send a v2 out today. > * ps/reftable-write-options (2024-05-10) 11 commits > - refs/reftable: allow configuring geometric factor > - reftable: make the compaction factor configurable > - refs/reftable: allow disabling writing the object index > - refs/reftable: allow configuring restart interval > - reftable: use `uint16_t` to track restart interval > - refs/reftable: allow configuring block size > - reftable/dump: support dumping a table's block structure > - reftable/writer: improve error when passed an invalid block size > - reftable/writer: drop static variable used to initialize strbuf > - reftable: consistently pass write opts as value > - reftable: consistently refer to `reftable_write_options` as `opts` > > The knobs to tweak how reftable files are written have been made > available as configuration variables. > > Will merge to 'next'? > source: <cover.1715336797.git.ps@xxxxxx> This one is ready from my point of view. > * ps/pseudo-ref-terminology (2024-05-10) 10 commits > - refs: refuse to write pseudorefs > - ref-filter: properly distinuish pseudo and root refs > - refs: pseudorefs are no refs > - refs: classify HEAD as a root ref > - refs: root refs can be symbolic refs > - refs: refname `is_special_ref()` to `is_pseudo_ref()` > - refs: rename `is_pseudoref()` to `is_root_ref()` > - Documentation/glossary: define root refs as refs > - Documentation/glossary: clarify limitations of pseudorefs > - Documentation/glossary: redefine pseudorefs as special refs > > Terminology to call various ref-like things are getting > straightened out. > > Comments? > source: <cover.1715330206.git.ps@xxxxxx> There have been a bunch of comments on these topics already, and overall they have been positive. Is there something specific that you want to see here? Thanks! Patrick
Attachment:
signature.asc
Description: PGP signature