Re: [PATCH v2 2/2] add-patch: do not print hunks repeatedly

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hi Rubén

On 26/03/2024 00:17, Rubén Justo wrote:
     $ git add -p
     diff --git a/add-patch.c b/add-patch.c
     index 52be1ddb15..8fb75e82e2 100644
     --- a/add-patch.c
     +++ b/add-patch.c
     @@ -1394,7 +1394,7 @@ N_("j - leave this hunk undecided, see next undecided hunk\n"
      static int patch_update_file(struct add_p_state *s,
      			     struct file_diff *file_diff)
      {
     -	size_t hunk_index = 0;
     +	size_t hunk_index = 0, prev_hunk_index = -1;
      	ssize_t i, undecided_previous, undecided_next;
      	struct hunk *hunk;
      	char ch;
     (1/4) Stage this hunk [y,n,q,a,d,j,J,g,/,e,p,?]? U
     y - stage this hunk
     n - do not stage this hunk
     q - quit; do not stage this hunk or any of the remaining ones
     a - stage this hunk and all later hunks in the file
     d - do not stage this hunk or any of the later hunks in the file
     j - leave this hunk undecided, see next undecided hunk
     J - leave this hunk undecided, see next hunk
     g - select a hunk to go to
     / - search for a hunk matching the given regex
     e - manually edit the current hunk
     p - print again the current hunk
     ? - print help
     @@ -1394,7 +1394,7 @@ N_("j - leave this hunk undecided, see next undecided hunk\n"
      static int patch_update_file(struct add_p_state *s,
      			     struct file_diff *file_diff)
      {
     -	size_t hunk_index = 0;
     +	size_t hunk_index = 0, prev_hunk_index = -1;
      	ssize_t i, undecided_previous, undecided_next;
      	struct hunk *hunk;
      	char ch;
     (1/4) Stage this hunk [y,n,q,a,d,j,J,g,/,e,p,?]?

Printing the chunk again followed by the question can be confusing as
the user has to pay special attention to notice that the same chunk is
being reconsidered.

As we print a long help message if we don't re-display the hunk it ends up being separated from the prompt. Personally I find the help message quite annoying when I've fat-fingered the wrong key - I'd prefer a shorter message pointing to "?" to display more help. We already do something similar if the user presses a key such as "s" that is disabled for the current hunk.

It can also be problematic if the chunk is longer than one screen height
because the result of the previous iteration is lost off the screen (the
help guide in the previous example).

To avoid such problems, stop printing the chunk if the iteration does
not advance to a different chunk.

Signed-off-by: Rubén Justo <rjusto@xxxxxxxxx>
---
  add-patch.c | 18 ++++++++++++------
  1 file changed, 12 insertions(+), 6 deletions(-)

diff --git a/add-patch.c b/add-patch.c
index 444fd75b2a..54a7d9c01f 100644
--- a/add-patch.c
+++ b/add-patch.c
@@ -1394,7 +1394,7 @@ N_("j - leave this hunk undecided, see next undecided hunk\n"
  static int patch_update_file(struct add_p_state *s,
  			     struct file_diff *file_diff)
  {
-	size_t hunk_index = 0;
+	size_t hunk_index = 0, prev_hunk_index = -1;

I found the name a bit confusing as we have keys for displaying the previous hunk and it make me think of that. As it is used to record the index of the hunk that we've rendered perhaps "rendered_hunk_index" would be a better name. Also as it needs to hold a negative value we should declare it as ssize_t like the variables on the line below.

  	ssize_t i, undecided_previous, undecided_next;
  	struct hunk *hunk;
  	char ch;
@@ -1448,10 +1448,14 @@ static int patch_update_file(struct add_p_state *s,
strbuf_reset(&s->buf);
  		if (file_diff->hunk_nr) {
-			render_hunk(s, hunk, 0, colored, &s->buf);
-			fputs(s->buf.buf, stdout);
+			if (prev_hunk_index != hunk_index) {
+				render_hunk(s, hunk, 0, colored, &s->buf);
+				fputs(s->buf.buf, stdout);
+				strbuf_reset(&s->buf);
+
+				prev_hunk_index = hunk_index;
+			}
- strbuf_reset(&s->buf);

I'd be inclined to leave this line as is to make it clear that the strbuf is always cleared before adding the keybindings.

  			if (undecided_previous >= 0) {
  				permitted |= ALLOW_GOTO_PREVIOUS_UNDECIDED_HUNK;
  				strbuf_addstr(&s->buf, ",k");
@@ -1649,10 +1653,12 @@ static int patch_update_file(struct add_p_state *s,
  			if (!(permitted & ALLOW_SPLIT))

style: as you're adding braces to the other clause in this if statement you should add them to this clause as well.

Best Wishes

Phillip




[Index of Archives]     [Linux Kernel Development]     [Gcc Help]     [IETF Annouce]     [DCCP]     [Netdev]     [Networking]     [Security]     [V4L]     [Bugtraq]     [Yosemite]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Linux SCSI]     [Fedora Users]

  Powered by Linux