On Sat, Aug 14, 2021 at 2:20 PM Junio C Hamano <gitster@xxxxxxxxx> wrote: > > "Azeem Bande-Ali via GitGitGadget" <gitgitgadget@xxxxxxxxx> writes: > > > + char* answer; > > Some people seem to make an asterisk stick to types like this, but > in our codebase written in C, an asterisk sticks to the identifier > that it makes into a pointer, i.e. > > char *answer; > Thanks! Will fix. I appreciate you providing the motivation for the policy as well! > > + struct strbuf msg = STRBUF_INIT; > > + strbuf_addf(&msg, _("Run '%s' instead? (y/N)"), > > + assumed); > > I think these should be kept on a single line for readability, i.e. > > strbuf_addf(&msg, _("Run '%s' instead? (y/N)"), assumed); > > as I see a fairly long line after this block already. > > fprintf_ln(stderr, _("git: '%s' is not a git command. See 'git --help'."), cmd); The line split was done by clang-format via `make style`. Is it okay to ignore the clang-format recommendation? (Incidentally `make style` would have also caught the first issue, I seem to have not run it after making a change in that line.) > Other than these cosmetic bits, this round looks good to me, > including the documentation update. Great thanks! This is my first patch so I just wanted to confirm: should I add a "Reviewed-by:" line to the commit with your name as well?