"Azeem Bande-Ali via GitGitGadget" <gitgitgadget@xxxxxxxxx> writes: > @@ -618,7 +628,17 @@ const char *help_unknown_cmd(const char *cmd) > _("Continuing under the assumption that " > "you meant '%s'."), > assumed); > - else { > + else if (autocorrect == AUTOCORRECT_PROMPT) { > + char* answer; Some people seem to make an asterisk stick to types like this, but in our codebase written in C, an asterisk sticks to the identifier that it makes into a pointer, i.e. char *answer; This is because doing so differently would confuse novices with constructs like this: int* a, b; where only 'a' is a pointer, and 'b' is not. > + struct strbuf msg = STRBUF_INIT; > + strbuf_addf(&msg, _("Run '%s' instead? (y/N)"), > + assumed); I think these should be kept on a single line for readability, i.e. strbuf_addf(&msg, _("Run '%s' instead? (y/N)"), assumed); as I see a fairly long line after this block already. fprintf_ln(stderr, _("git: '%s' is not a git command. See 'git --help'."), cmd); Other than these cosmetic bits, this round looks good to me, including the documentation update. Thanks.