Avishay Matayev wrote: > On Wed, 23 Jun 2021 at 04:57, Felipe Contreras > <felipe.contreras@xxxxxxxxx> wrote: > > Seems like a completely sensible request to me, except I would do it a > > slightly different place: > > > > --- a/pager.c > > +++ b/pager.c > > @@ -101,7 +101,7 @@ void prepare_pager_args(struct child_process *pager_process, const char *pager) > > > > void setup_pager(void) > > { > > - const char *pager = git_pager(isatty(1)); > > + const char *pager = git_pager(git_env_bool("GIT_PAGER_FORCE", isatty(1))); > > > > if (!pager) > > return; > > > > I'm Cc'ing Jonathan Nieder who seems to have toched these lines. > > Well I'm glad to hear you find it sensible, though your patch suggests > that `GIT_PAGER_FORCE` will be a boolean, while I expect it to be an > actual pager, which would make more sense IMO. I just copied the idea from the GitHub issue, I find it simple and easy to implement in the code this way. A GIT_PAGER_FORCE as you suggest would be a bit more complicated. Either way feel free to provide a patch with whatever approach you think is best. However, for a proper patch you need to add documentation too (see Documentation/git-var.txt), and preferably some tests. Cheers. -- Felipe Contreras