Re: [PATCH][GSoC] submodule: introduce add-clone helper for submodule add

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 




> On 02-Jun-2021, at 13:25, Atharva Raykar <raykar.ath@xxxxxxxxx> wrote:
> 
> [...]
> I've not yet fully developed a taste for good C style, so I wanted
> to ask, which one looks better to you in these?
> 
> /* Sample 1 */
> while (begin != end && (line = get_next_line(begin, end))) {
> 	char *name, *url, *tail;
> 	name = parse_token(&begin, next_line);
> 	url = parse_token(&begin, next_line);
> 	tail = parse_token(&begin, next_line);
> 	...
> }
> 
> /* Sample 2 */
> while (begin != end && (line = get_next_line(begin, end))) {
> 	char *name = parse_token(&begin, next_line);
> 	char *url = parse_token(&begin, next_line);
> 	char *tail = parse_token(&begin, next_line);
> 	...
> }

Also ignore the error here, assume: s/next_line/line/
(Anyway, my question was about style)



[Index of Archives]     [Linux Kernel Development]     [Gcc Help]     [IETF Annouce]     [DCCP]     [Netdev]     [Networking]     [Security]     [V4L]     [Bugtraq]     [Yosemite]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Linux SCSI]     [Fedora Users]

  Powered by Linux