Re: [PATCH] merge-ort: split "distinct types" message into two translatable messages

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Sun, May 9, 2021 at 2:53 PM Alex Henrie <alexhenrie24@xxxxxxxxx> wrote:
>
> The word "renamed" has two possible translations in many European
> languages depending on whether one thing was renamed or two things were
> renamed. Give translators freedom to alter any part of the message to
> make it sound right in their language.
>
> Signed-off-by: Alex Henrie <alexhenrie24@xxxxxxxxx>
> ---
>  merge-ort.c | 21 +++++++++++++++------
>  1 file changed, 15 insertions(+), 6 deletions(-)
>
> diff --git a/merge-ort.c b/merge-ort.c
> index 6c2792b10e..745a844b18 100644
> --- a/merge-ort.c
> +++ b/merge-ort.c
> @@ -3050,12 +3050,21 @@ static void process_entry(struct merge_options *opt,
>                                 rename_b = 1;
>                         }
>
> -                       path_msg(opt, path, 0,
> -                                _("CONFLICT (distinct types): %s had different "
> -                                  "types on each side; renamed %s of them so "
> -                                  "each can be recorded somewhere."),
> -                                path,
> -                                (rename_a && rename_b) ? _("both") : _("one"));
> +                       if (rename_a && rename_b) {
> +                               path_msg(opt, path, 0,
> +                                        _("CONFLICT (distinct types): %s had "
> +                                          "different types on each side; "
> +                                          "renamed both of them so each can "
> +                                          "be recorded somewhere."),
> +                                        path);
> +                       } else {
> +                               path_msg(opt, path, 0,
> +                                        _("CONFLICT (distinct types): %s had "
> +                                          "different types on each side; "
> +                                          "renamed one of them so each can be "
> +                                          "recorded somewhere."),
> +                                        path);
> +                       }
>
>                         ci->merged.clean = 0;
>                         memcpy(new_ci, ci, sizeof(*new_ci));
> --
> 2.31.1

I don't know much on the translation side (thanks for fixing it up for
me), but looks innocuous and correct from the code side:

Acked-by: Elijah Newren <newren@xxxxxxxxx>



[Index of Archives]     [Linux Kernel Development]     [Gcc Help]     [IETF Annouce]     [DCCP]     [Netdev]     [Networking]     [Security]     [V4L]     [Bugtraq]     [Yosemite]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Linux SCSI]     [Fedora Users]

  Powered by Linux