Denton Liu <liu.denton@xxxxxxxxx> writes: > +In the case where one commit is given, a diff is displayed between the > +merge base and the working tree or the index if `--cached` is given. s/merge base/& between the commit and the HEAD/ As "merge base" in the context of talking about "one commit" does not make sense, such a clarification would be necessary. Jonathan suggested "--fork-point A B"; this replaces it with "--merge-base A B". Neither is quite satisfying, but other people might be able to come up with a better names. In any case, "git diff $(git merge-base MERGE_HEAD HEAD)" while merging to see how the changes in the working tree look like is something I've always felt cumbersome to spell, and this is a good addition. > + OPT_BOOL(0, "merge-base", &merge_base, > + N_("use the merge base between the two commits as the diff base")) Define "diff base". Eh, that was rhetoric---do not use such an undefined word. "compare with the merge base between two commits" may work better.