Re: [PATCH v2] l10n: reformat some localized strings for v2.23.0

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Sat, Aug 03, 2019 at 09:59:07PM +0200, Jean-Noël Avila wrote:

> Signed-off-by: Jean-Noël Avila <jn.avila@xxxxxxx>
> ---
>  builtin/checkout.c |  2 +-
>  builtin/fetch.c    | 15 +++++++++++----
>  2 files changed, 12 insertions(+), 5 deletions(-)
> 
> diff --git a/builtin/checkout.c b/builtin/checkout.c
> index 91f8509f85..08e19ed1ed 100644
> --- a/builtin/checkout.c
> +++ b/builtin/checkout.c
> @@ -1769,7 +1769,7 @@ int cmd_restore(int argc, const char **argv, const char *prefix)
>  	struct option *options;
>  	struct option restore_options[] = {
>  		OPT_STRING('s', "source", &opts.from_treeish, "<tree-ish>",
> -			   N_("where the checkout from")),
> +			   N_("where the checkout is from")),

I think your original "where to checkout from" is better.

As a native speaker, "where the checkout is from" implies that checkout
is a noun that is being described. But I think we want checkout to be a
verb (because we are talking about the operation), and the option tells
Git how to do that operation.

(I agree the original "where the checkout from" is nonsense).

> diff --git a/builtin/fetch.c b/builtin/fetch.c
> index 53ce99d2bb..0e8760e5d4 100644
> --- a/builtin/fetch.c
> +++ b/builtin/fetch.c
> @@ -850,6 +850,15 @@ static int iterate_ref_map(void *cb_data, struct object_id *oid)
>  	return 0;
>  }
>  
> +static char warn_show_forced_updates[] =
> +N_("Fetch normally indicates which branches had a forced update, but that\n"
> +   "check has been disabled. To re-enable, use '--show-forced-updates' flag\n"
> +   "or run 'git config fetch.showForcedUpdates true'.");

This one isn't a typo fix, right? It's just putting the two warning()
calls into a single message. I can see how this would be useful for
translators, but note that the output will be different. The original
would be something like:

  warning: Fetch normally indicates...
  warning: To re-enable...

where now we'd get:

  warning: Fetch normally indicates...
  check has been disabled...
  or run 'git config...

which might be a bit harder to read because the wrapped lines lose the
prefix. For advise() we nicely pick out the newlines and prefix each
line individually, but warning(), error(), etc, don't do that. Maybe
they should.

That's too big for this late in the -rc cycle, I think. In the meantime,
I'm not sure which (the original or your patch) is the least-bad
solution. :)

This change (if I am right that there's no actual typo fix) should
perhaps be in a separate patch from the earlier hunk, though.

-Peff



[Index of Archives]     [Linux Kernel Development]     [Gcc Help]     [IETF Annouce]     [DCCP]     [Netdev]     [Networking]     [Security]     [V4L]     [Bugtraq]     [Yosemite]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Linux SCSI]     [Fedora Users]

  Powered by Linux