This patch ultimately aims to replace `test -(d|f|e|s)` calls in t3600-rm.sh Previously we were using these to verify the presence of diretory/file, but we already have helper functions, viz, `test_path_is_dir`, `test_path_is_file`, `test_path_is_missing` and `test_file_not_empty` with better functionality Helper functions are better as they provide better error messages and improve readability. They are friendly to someone new to code. Thanks Rohit PS: `test_file_not_empty` is implemented in [PATCH v2 1/3] of this mail Rohit Ashiwal (3): test functions: add function `test_file_not_empty` t3600: restructure code according to contemporary guidelines t3600: use helpers to replace test -d/f/e/s <path> t/t3600-rm.sh | 326 ++++++++++++++++++++-------------------- t/test-lib-functions.sh | 15 ++ 2 files changed, 180 insertions(+), 161 deletions(-) -- 2.17.1