This patch ultimately aims to replace `test -(d|f|e|s)` calls in t3600-rm.sh Previously we were using these to verify the presence of diretory/file, but we already have helper functions, viz, `test_path_is_dir`, `test_path_is_file`, `test_path_is_missing` and `test_file_not_empty` with better functionality Helper functions are better as they provide better error messages and improve readability. They are friendly to someone new to code. Note: `test_file_not_empty` is implemented in [PATCH 1/3] of this mail Rohit Ashiwal (3): test functions: Add new function `test_file_not_empty` t3600: refactor code according to contemporary guidelines t3600: use helper functions from test-lib-functions t/t3600-rm.sh | 281 +++++++++++++++++++++------------------- t/test-lib-functions.sh | 10 ++ 2 files changed, 157 insertions(+), 134 deletions(-) -- Thanks Rohit