Adam Roben <aroben@xxxxxxxxx> writes: > On Jun 26, 2007, at 10:21 PM, Junio C Hamano wrote: > ... >>> +my ($threaded, $chain_reply_to, $quiet, $suppress_from, >>> $no_signed_off_cc, >>> + $dry_run) = (1, 1, 0, 0, 0, 0); >> >> While we are at it, you might want to make everything other than >> quiet and dry_run overridable the same way. > > --[no-]chain-reply-to, --suppress-from and --no-signed-off-cc > already exist, so do you mean that we should support --no-suppress- > from and --signed-off-cc (i.e., the negations) as well? Or that we > should have equivalent config settings for these? Or both? Sorry for being unclear; I was talking about the config. Also "my ($a, $b, $c, ...) = ($defA, $defB, $defC, ...)" gets extremely hard to read when the list grows longer. I was hoping that when adding entries to %config_settings array, you would do something like: my %config_settings = ( threaded => [\threaded, 1], chainreplyto => [\chain_reply_to, 1], ... ); while (my ($var, $data) = each %config_settings) { my $config = $repo_config_bool("sendemail.$var); ${$data->[0]} = (defined $config) ? $config : $data->[1]; } - To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html