Jonathan Tan <jonathantanmy@xxxxxxxxxx> writes: > This is on _both_ ds/commit-graph-fsck and sb/object-store-lookup, > following Stolee's suggestion. > > (It also seems better to build it this way to me, since both these > branches are going into "next" according to the latest What's Cooking.) OK. I am perfectly OK if this left lookup_commit() with older function signature and instead asked the integrator to fix up with evil merge with sb/object-store-lookup, but given that this topic is no more urgent than the other one, making them intertwined is fine. Merging ds/commit-graph-fsck into sb/object-store-lookup already requires an evil merge to build correctly due to this new parameter. I really wish we did the more canonical "do not change signature of a widely used function. If the widely used one is a mere specialization that calls the new one with the default parameter, make that widely used one a thin wraper (or a macro) of the new one" approach to avoid having to repeatedly create such pointless evil merges X-<. > Makefile | 1 + > builtin/commit-graph.c | 2 + > builtin/fsck.c | 2 +- > cache.h | 1 - > commit-graph.c | 108 +++++++++++++++++++++---------------- > commit-graph.h | 11 ++-- > commit.c | 6 +-- > config.c | 5 -- > environment.c | 1 - > object-store.h | 6 +++ > object.c | 5 ++ > ref-filter.c | 2 +- > t/helper/test-repository.c | 82 ++++++++++++++++++++++++++++ > t/helper/test-tool.c | 1 + > t/helper/test-tool.h | 1 + > t/t5318-commit-graph.sh | 35 ++++++++++++ > 16 files changed, 207 insertions(+), 62 deletions(-) > create mode 100644 t/helper/test-repository.c