Samuel Lijin <sxlijin@xxxxxxxxx> writes: > We want to use cmp_name() and check_contains() (which both compare > `struct dir_entry`s, the former in terms of the sort order, the latter > in terms of whether one lexically contains another) outside of dir.c, > so we have to (1) change their linkage and (2) rename them as > appropriate for the global namespace. The second is achieved by > renaming cmp_name() to cmp_dir_entry() and check_contains() to > check_dir_entry_contains(). > > Signed-off-by: Samuel Lijin <sxlijin@xxxxxxxxx> > --- > dir.c | 11 ++++++----- > dir.h | 3 +++ > 2 files changed, 9 insertions(+), 5 deletions(-) Up to this point in the series all looked sensible. I haven't looked the last one carefully to form an opinion yet. Thanks.