Hi, On Tue, 16 Aug 2016, Remi Galan Alfonso wrote: > Stephen Morton <stephen.morton@xxxxxxxxx> writes: > > + if (multiple_commits) > > + advise(_("after resolving the conflicts, > > mark the corrected paths with 'git add <paths>' or 'git rm <paths>'\n" > > + "then continue with 'git %s > > --continue'\n" > > + "or cancel with 'git %s > > --abort'" ), action_name(opts), action_name(opts)); > > + else > > + advise(_("after resolving the > > conflicts, mark the corrected paths\n" > > + "with 'git add <paths>' or 'git > > rm <paths>'\n" > > + "and commit the result with > > 'git commit'")); > > In both cases (multiple_commits or not), the beginning of the advise > is nearly the same, with only a '\n' in the middle being the > difference: > > multiple_commits: > "after resolving the conflicts, mark the corrected paths with 'git > add <paths>' or 'git rm <paths>'\n" > > !multiple_commits: > "after resolving the conflicts, mark the corrected paths\n with 'git > add <paths>' or 'git rm <paths>'\n" > ~~~~~~~^ > > In 'multiple_commits' case the advise is more than 80 characters long, > did you forget the '\n' in that case? > > If you end up using the same beginning of advice, maybe it's possible > to give it before the 'if(multiple_commits)' and avoid duplication of > the lines. I concur with this, and also with Christian's advice to append the parameter consistently as last one, and also with renaming it to "last_commit". Ciao, Johannes -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html