On Mon, Nov 23, 2015 at 10:44 AM, Stefan Beller <sbeller@xxxxxxxxxx> wrote: > On Fri, Nov 20, 2015 at 10:58 PM, Torsten Bögershausen <tboegi@xxxxxx> wrote: >> On 2015-11-20 22.08, Stefan Beller wrote: >> The patch looks good at first glance, one minor remark below: >>> >>> diff --git a/run-command.c b/run-command.c >> >>> @@ -1071,70 +1089,31 @@ static void pp_output(struct parallel_processes *pp) >>> >>> static int pp_collect_finished(struct parallel_processes *pp) >>> { >>> - int i = 0; >>> - pid_t pid; >>> - int wait_status, code; >>> + int i, code; >> >> code is probably "return code"? >> woud "ret_value", "res" or "rc" make that more clear ? >> > Although looking through the code, we have lots of functions having a local `code` variable, so we may want to preserve consistency across the different functions to have a `code`which contains the return value of the process or function invoked. We had the `code` already in pp_collect_finished, so I'd like to not rename a variable (which was used for the same purpose) in this patch. In pp_start_one we introduce a new variable `code` which contains the return from the user callback function, so I would understand if we were arguing there. That said, I plan to resend with a reworded commit message later today. -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html