Re: [PATCH] branch.c: simplify chain of if statements

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Dragos Foianu <dragos.foianu@xxxxxxxxx> writes:

> +	const char *verbose_prints[4] = {
> +		"Branch %s set up to track remote branch %s from %s%s",
> +		"Branch %s set up to track local branch %s%s",
> +		"Branch %s set up to track remote ref %s%s",
> +		"Branch %s set up to track local ref %s%s"
> +	};
> +	char *verbose_rebasing = rebasing ? " by rebasing." : ".";
> +

This seems to be a "lego construct" that makes translation harder: are
you sure that the "by rebasing" will be at the end of the sentence in
any languages?

Also, this lacks the _() on verbose_rebasing, which isn't translatable
anymore after your patch.

I personnally think that the table-driven approach is wrong here, it
makes the code shorter but much harder to read.

-- 
Matthieu Moy
http://www-verimag.imag.fr/~moy/
--
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html




[Index of Archives]     [Linux Kernel Development]     [Gcc Help]     [IETF Annouce]     [DCCP]     [Netdev]     [Networking]     [Security]     [V4L]     [Bugtraq]     [Yosemite]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Linux SCSI]     [Fedora Users]