On Thursday 2007 January 25 23:44, Junio C Hamano wrote: > I do agree the original patch conflates many different things, > and it would be nicer to do this clean-up as separate pieces. FYI: As you know I've got some patches that fix use of literal numbers for the hash sizes instead of SOME_CONSTANT. I've further got one that does the same for the literal uses of "refs/" et al. I'm holding off on these until after 1.5 so as to minimise big changes. > * The official name of these 40-hexdigit thingy we use to name > objects is "object name" (see Documentation/glossary.txt). As a further to the above cleanups, I'm also planning to fix all the sha1 named variables to be "hash" or "object" or something. It strikes me that this plan is related to this cleanup and might fix some of the issues like: > + "git-read-tree (<sha> | " > + "[[-m [--aggressive] | --reset | --prefix=<prefix>] " > + "[-u | -i]] [--exclude-per-directory=<gitignore>] " > + "<sha1> [<sha2> [<sha3>]])"; The reasons for wanting this are, I hope, obvious. The variables (and parameters) accept object-names not SHA-1 hashes. The fact that the objects are named after a SHA-1 isn't relevant to users; and shouldn't be relevant for the variable names, simply to promote abstraction from what the actual hash function is. I mention it here because it seems to fit with this cleanup theme. Am I still correct that you would want this sort of thing post-1.5? Is it even a reasonable goal to have? Andy -- Dr Andy Parkins, M Eng (hons), MIEE andyparkins@xxxxxxxxx - To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html