On Thursday 2007 January 18 13:57, Johannes Schindelin wrote: I think this would be clearer if next were renamed... > +struct commit_list *reverse_commit_list(struct commit_list *list) > +{ > + struct commit_list *prev = NULL, *current, *backup; > + for (current = list; current; current = backup) { > + backup = current->next; > + current->next = prev; > + prev = current; > + } > + return next; > +} Andy -- Dr Andy Parkins, M Eng (hons), MIEE andyparkins@xxxxxxxxx - To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html