Jeff King <peff@xxxxxxxx> writes: > Is it worth having a strbuf_set* family of functions to match the > strbuf_add*? We seem to have these sorts of errors with strbuf from time > to time, and I wonder if that would make it easier (and more readable) > to do the right thing. Possibly. The callsite below may be a poor example, though; you would need the _reset() even if you change the _addstr() we can see in the context to _setstr() to make sure later strbuf_*(type) will start from a clean slate when !t anyway, no? > > http.c | 1 + > 1 file changed, 1 insertion(+) > > diff --git a/http.c b/http.c > index d868d8b..d9d1aad 100644 > --- a/http.c > +++ b/http.c > @@ -841,6 +841,7 @@ static int http_request(const char *url, struct strbuf *type, > > if (type) { > char *t; > + strbuf_reset(type); > curl_easy_getinfo(slot->curl, CURLINFO_CONTENT_TYPE, &t); > if (t) > strbuf_addstr(type, t); -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html