On 07/16/2012 07:47 PM, Junio C Hamano wrote:
Michael Haggerty <mhagger@xxxxxxxxxxxx> writes:
It's already supported:
git config hooks.announcelist \
"nosy@xxxxxxxxxxx, overwhelmed@xxxxxxxxxxx, phb@xxxxxxxxxxx"
git config hooks.refchangelist \
"nosy@xxxxxxxxxxx, overwhelmed@xxxxxxxxxxx"
git config hooks.commitlist "nosy@xxxxxxxxxxx"
Sad. Is the "post-recieve email" squatting on the _whole_ hooks.*
namespace, not postreceiveemailhook.* or something more reasonably
limited?
Yes. I didn't like this either, but I copied this aspect of the old
script in the interest of compatibility.
If we want to change this, now would be a good time, before the new
script starts using more of the hooks namespace. One could choose a new
namespace and deprecate the old one, optionally in multiple steps:
1. Only read new options from new namespace; read old options from new
namespace or (if the new names are not set) falling back to the old
namespace.
2. Deprecate the old namespace, emitting warnings if the old names are
still set but continuing to use them.
3. Stop supporting the old namespace, but emit warnings if the old names
are still set.
4. Stop looking in the old namespace altogether.
Though, given that hook scripts have to be enabled/upgraded
per-repository, usually on a central server, probably doing only steps 2
and 4 would be enough.
Michael
--
Michael Haggerty
mhagger@xxxxxxxxxxxx
http://softwareswirl.blogspot.com/
--
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html