On Fri, Feb 24, 2012 at 03:48:10PM -0500, Jeff King wrote: > On Fri, Feb 24, 2012 at 12:03:17PM -0800, Junio C Hamano wrote: > > > > - else if (size <= big_file_threshold || type != OBJ_BLOB) > > > + else if (size <= big_file_threshold || type != OBJ_BLOB || > > > + convert_to_git(path, NULL, 0, NULL, 0)) > > > > Nice. It would be even nicer to give a readability macro whose name makes > > it clear that this is a query (unfortunately we cannot add '?' at the end > > of the function name) and not a conversion. Any name suggestions? > > Yeah, I cringed a little at all of the NULLs. How about: > > int would_convert_to_git(const char *path); > > ? I started to do this but had a thought: would other callers want more flexibility? That is, should convert_to_git's dry run trigger actually be: the _destination_ buffer is NULL? I.e., you could call it like this: convert_to_git(path, buf, len, NULL, 0); and find out the real answer, including inspecting buf, about whether we would convert. Or you could also use a NULL buffer to get the pessimistic "we might convert" case. I don't think it really matters that much, as I am introducing only one caller. I'm not sure if any other code paths would care about this speculative "maybe we would convert" question, so perhaps it is simply over-engineering. -Peff -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html