Jonathan Nieder <jrnieder@xxxxxxxxx> writes: > off_t delta_len = off_t_or_die(len, "enormous delta"); > postimage_len = apply_delta(delta_len, input, ...); > > What do you think? Another possibility would be to make the "die" part responsibility of the caller of the helper function, e.g. if (value_out_of_range(off_t, len)) die("enormous delta"); which may make the caller easier to follow and the helper easier to reuse. -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html