[PATCH 0/3] avoiding unintended consequences of git_path() usage

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Ramkumar Ramachandra wrote:
> Junio C Hamano wrote:

>> Or perhaps http://thread.gmane.org/gmane.comp.version-control.git/184963/focus=185436
>
> I noticed that sha1_to_hex() also operates like this.  The
> resolve_ref() function is really important, but using the same
> technique for these tiny functions is probably an overkill

I don't follow.  Do you mean that not being confusing is overkill,
because the function is small that no one will bother to look up the
right semantics?  Wait, that sentence didn't come out the way I
wanted. ;-)

Jokes aside, here's a rough series to do the git_path ->
git_path_unsafe renaming.  While writing it, I noticed a couple of
bugs, hence the two patches before the last one.  Patch 2 is the more
interesting one.

Patches are against "master", but patch 2 probably should be thought
of as being against maint-1.7.6.  Improvements welcome, as always.

Thanks,

Jonathan Nieder (3):
  do not let git_path clobber errno when reporting errors
  Bigfile: dynamically allocate buffer for marks file name
  rename git_path() to git_path_unsafe()

 Documentation/technical/api-string-list.txt |    5 +-
 attr.c                                      |    2 +-
 bisect.c                                    |    8 ++--
 branch.c                                    |   12 ++--
 builtin/add.c                               |    2 +-
 builtin/commit.c                            |   57 ++++++++++++-----------
 builtin/config.c                            |    4 +-
 builtin/fetch-pack.c                        |    4 +-
 builtin/fetch.c                             |    5 +-
 builtin/fsck.c                              |    2 +-
 builtin/init-db.c                           |   12 ++--
 builtin/merge.c                             |   67 +++++++++++++++------------
 builtin/notes.c                             |    2 +-
 builtin/remote.c                            |    6 +-
 builtin/reset.c                             |    2 +-
 builtin/revert.c                            |   25 +++++-----
 cache.h                                     |    3 +-
 contrib/examples/builtin-fetch--tool.c      |    4 +-
 dir.c                                       |    2 +-
 fast-import.c                               |    2 +-
 http-backend.c                              |    2 +-
 notes-merge.c                               |   22 +++++----
 pack-refs.c                                 |    6 +-
 path.c                                      |    2 +-
 refs.c                                      |   51 +++++++++++---------
 remote.c                                    |    4 +-
 rerere.c                                    |   12 ++--
 run-command.c                               |    4 +-
 sequencer.c                                 |    6 +-
 server-info.c                               |    2 +-
 sha1_file.c                                 |   22 ++++++--
 shallow.c                                   |    2 +-
 transport.c                                 |    4 +-
 unpack-trees.c                              |    2 +-
 34 files changed, 200 insertions(+), 167 deletions(-)

-- 
1.7.8.rc0

--
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[Index of Archives]     [Linux Kernel Development]     [Gcc Help]     [IETF Annouce]     [DCCP]     [Netdev]     [Networking]     [Security]     [V4L]     [Bugtraq]     [Yosemite]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Linux SCSI]     [Fedora Users]