David Caldwell <david@xxxxxxxxxxxx> writes: > @@ -49,6 +57,7 @@ clear_stash () { > > create_stash () { > stash_msg="$1" > + untracked="$2" Hmm... > @@ -173,7 +213,7 @@ save_stash () { > test -f "$GIT_DIR/logs/$ref_stash" || > clear_stash || die "Cannot initialize stash" > > - create_stash "$stash_msg" > + create_stash "$stash_msg" $untracked Just a minor nit from internal API point of view, I would prefer to see something like create_stash --untracked=all "message" or even create_stash --untracked=all --message="message" once you start enriching these functions with optional behaviour. -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html