Re: [PATCH 13/15] gettextize: git-revert messages using the "me" variable

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Mon, Sep 6, 2010 at 18:50, Jonathan Nieder <jrnieder@xxxxxxxxx> wrote:
> (+cc: Christian, de facto cherry-pick maintainer)

Thanks. In most cases I haven't been CC-ing people,

a) because I'd probably end up CC-ing everyone who ever touched git

b) the nature of the changes probalby doesn't especially benefit from
   me bothering all these people. But maybe that's the wrong assumption.

But by all means add more people to the CC :)

> Ævar Arnfjörð Bjarmason wrote:
>
>> Mark messages that used the "me" variable for translation. The
>> potential values of the variable had already been marked using N_(),
>> so we can use _(me) here.
>
> Ah, now I understand better.  Would it be possible to squash this
> patch with the previous one (for clarity)?

And now I see the reply I just sent off was useless, oh well, that's
what I get for reading things sequentially :)

Sure, it can be squashed. I'm just trying to keep things as granular
as possible, but maybe I'm overshooting it in some cases.

>> --- a/builtin/revert.c
>> +++ b/builtin/revert.c
>> @@ -286,10 +286,10 @@ static NORETURN void die_dirty_index(const char *me)
>>               die_resolve_conflict(me);
>>       } else {
>>               if (advice_commit_before_merge)
>> -                     die("Your local changes would be overwritten by %s.\n"
>> -                         "Please, commit your changes or stash them to proceed.", me);
>> +                     die(_("Your local changes would be overwritten by %s.\n"
>> +                         "Please, commit your changes or stash them to proceed."), _(me));
>>               else
>> -                     die("Your local changes would be overwritten by %s.\n", me);
>> +                     die(_("Your local changes would be overwritten by %s.\n"), _(me));
>
> Good.
>
>> @@ -339,7 +339,7 @@ static int do_recursive_merge(struct commit *base, struct commit *next,
>>       if (active_cache_changed &&
>>           (write_cache(index_fd, active_cache, active_nr) ||
>>            commit_locked_index(&index_lock)))
>> -             die("%s: Unable to write new index file", me);
>> +             die(_("%s: Unable to write new index file"), _(me));
>
> Not good, in my opinion.  The dialogue ought to look like this, I think:
>
>  $ git cherry-pick astermay
>  ...
>  fatal: cherry-pick: Unableway otay itewray ewnay indexway ilefay
>
>> @@ -446,8 +446,8 @@ static int do_pick_commit(void)
>>               return fast_forward_to(commit->object.sha1, head);
>>
>>       if (parent && parse_commit(parent) < 0)
>> -             die("%s: cannot parse parent commit %s",
>> -                 me, sha1_to_hex(parent->object.sha1));
>> +             die(_("%s: cannot parse parent commit %s"),
>> +                 _(me), sha1_to_hex(parent->object.sha1));
>
> Likewise.
>
>> @@ -570,7 +570,7 @@ static int revert_or_cherry_pick(int argc, const char **argv)
>>       }
>>
>>       if (read_cache() < 0)
>> -             die("git %s: failed to read the index", me);
>> +             die(_("git %s: failed to read the index"), _(me));
>
> Likewise.

I don't know if all of the above hold true, e.g. because some
languages will always transliterate things, even proper nouns.

But as mentioned before the string is probably being used in too many
different contexts for it to be useful to them.

> With the exceptions mentioned above,

So I should probably just skip translating the "me" variable for now. I.e.
this and the last patch can probably be dropped.

> Reviewed-by: Jonathan Nieder <jrnieder@xxxxxxxxx>
--
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[Index of Archives]     [Linux Kernel Development]     [Gcc Help]     [IETF Annouce]     [DCCP]     [Netdev]     [Networking]     [Security]     [V4L]     [Bugtraq]     [Yosemite]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Linux SCSI]     [Fedora Users]