Michael Olson <mwolson@xxxxxxx> wrote: > On Tue, Apr 20, 2010 at 4:58 PM, Junio C Hamano <gitster@xxxxxxxxx> wrote: > > Michael Olson <mwolson@xxxxxxx> writes: > > > >> [svn-remote "svn"] > >> url = https://svn.my.org/svn/root > >> ... > >> ignore-refs = ^refs/remotes/(tags/)?old/myorg > > > > Traditionally configuration variable names are spelled camelCase without > > dashes. You probably would want to be consistent. > > I was looking at the existing syntax for "ignore-paths", which uses > dashes. Should that be changed as well? Yes, I missed that the first time around :x I suppose that should be changed to work both ways. > > Also "refs" and any pathname-like things are traditionally matched using > > globs and not regexes. It is Ok to deviate if you have a strong reason to > > (and I suspect it would make it easier to write "exclude" patterns like > > the above example to allow a regex here), but that needs to be prominently > > documented (e.g. "Unlike any other ref-matching configuration variable, > > this alone uses regex, not glob") to avoid end user confusion. > > ignore-paths also uses a regex. I'm concerned that using globs will > not be expressive enough to represent a regex like (a combination of > the 2 use cases I posted initially): I also missed that (I never used that feature :x) > ^refs/remotes/((tags/)?old/myorg|old/bad_branch|old/unlabeled[^/]*|tags/(old/bad_tag|releases/another_tag))$ I wonder if both would be better as a series of globs would be easier to read (maybe more verbose to write): ignoreRefs = refs/remotes/tags/old/myorg ignoreRefs = refs/remotes/old/myorg ignoreRefs = refs/remotes/old/unlabeled/* But I suppose the regexp route is fine. I'll ack and push them out with Sam's Ack on 2/2 -- Eric Wong -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html