On Wed, Apr 14, 2010 at 7:06 AM, Jonathan Nieder <jrnieder@xxxxxxxxx> wrote: > So here are some ideas for future work (not necessarily in order). > > - Teach remaining commands that need to search for a repository to > use RUN_SETUP_GENTLY, with appropriate exceptions where needed > (for --no-index, for example). - Two patches "worktree setup: calculate prefix.." and "index-pack: trust the prefix" may form a separate series. That would unblock RUN_SETUP_GENTLY series. > - Introduce unset_git_directory and the RUN_UNSETUP option (yes, > this needs a better name). Teach commands that work without a > git directory to use it (this should fix the init poisoned by > parent repository and aliased init problems). - Two patches that move enter_repo() to setup.c and fix it up can go first. They should have no impact on system. > > - Teach git_config() to ignore the repository-specific configuration > if have_run_setup is true but have_repository is false. > > - Teach git_attr() to ignore .git/info/attributes if have_run_setup > is true but have_repository is false. > > - Teach git_config() to optionally die if have_run_setup is not true > and the setup_git_dir* to optionally die if have_run_setup is true. > test-lib.sh would enable this option. > - Introduce startup_info->prefix. I think that's a good change, but it's independent to this series. The reason is, prefix can change after setup_git_dir is called (i.e. setup_work_tree()). - The fix for "git cmd -h" can make a separate series (4 patches) - Finally the soft guard patch and assorted fixups to avoid warnings. I'll reorder my tree and see if it looks good. Patches of this 9-patch series will be untouched. -- Duy -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html