Michael Lukashov <michael.lukashov@xxxxxxxxx> writes: > diff --git a/merge-recursive.c b/merge-recursive.c > index cb53b01..5999ae2 100644 > --- a/merge-recursive.c > +++ b/merge-recursive.c > @@ -599,7 +599,7 @@ struct merge_file_info > merge:1; > }; > > -static void fill_mm(const unsigned char *sha1, mmfile_t *mm) > +void fill_mm(const unsigned char *sha1, mmfile_t *mm) > { > unsigned long size; > enum object_type type; Isn't a much better home for this function next to read_mmfile() in xdiff-interface.c? Perhaps it would make sense to morph it into something like this int read_mmblob(mmfile_t *ptr, const unsigned char *sha1); for consistency. -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html